using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(.*?)(_Capital))?(.*?)_(State.*)";
string substitution = @"\4\2_\1\3";
string input = @"Bokaro_State_Jharkhand
Ranchi_Capital_State_Jharkhand
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}