import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(.*?)(_Capital))?(.*?)_(State.*)";
final String string = "Bokaro_State_Jharkhand\n"
+ "Ranchi_Capital_State_Jharkhand\n\n";
final String subst = "\\4\\2_\\1\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}