re = /^(?:(.*?)(_Capital))?(.*?)_(State.*)/m
str = 'Bokaro_State_Jharkhand
Ranchi_Capital_State_Jharkhand
'
subst = '\\4\\2_\\1\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result