#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "www\w+:\/\/[\w.-]+(?::?\d{1,5})?[-\w.\/?=&%]*"
Local $sString = "http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423" & @CRLF & _
"https://localhost:443" & @CRLF & _
"mailto://www.domain.com:8080/something" & @CRLF & _
"http://www.domain.com/something:badurl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")