$re = '/www\w+:\/\/[\w.-]+(?::?\d{1,5})?[-\w.\/?=&%]*/';
$str = 'http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423
https://localhost:443
mailto://www.domain.com:8080/something
http://www.domain.com/something:badurl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);