import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "www\\w+:\\/\\/[\\w.-]+(?::?\\d{1,5})?[-\\w.\\/?=&%]*";
final String string = "http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423\n"
+ "https://localhost:443\n"
+ "mailto://www.domain.com:8080/something\n"
+ "http://www.domain.com/something:badurl";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}