const regex = /www\w+:\/\/[\w.-]+(?::?\d{1,5})?[-\w.\/?=&%]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('www\\w+:\\\/\\\/[\\w.-]+(?::?\\d{1,5})?[-\\w.\\\/?=&%]*', 'g')
const str = `http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423
https://localhost:443
mailto://www.domain.com:8080/something
http://www.domain.com/something:badurl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}