// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"www\w+:\/\/[\w.-]+(?::?\d{1,5})?[-\w.\/?=&%]*").unwrap();
let string = "http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423
https://localhost:443
mailto://www.domain.com:8080/something
http://www.domain.com/something:badurl";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}