use strict;
my $str = 'http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423
https://localhost:443
mailto://www.domain.com:8080/something
http://www.domain.com/something:badurl';
my $regex = qr/www\w+:\/\/[\w.-]+(?::?\d{1,5})?[-\w.\/?=&%]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}