package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`www\w+:\/\/[\w.-]+(?::?\d{1,5})?[-\w.\/?=&%]*`)
var str = `http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423
https://localhost:443
mailto://www.domain.com:8080/something
http://www.domain.com/something:badurl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}