using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-z]{2}|[a-z])\d.*$";
string input = @"AB1ghRjh
c1
G44
Tt7688
kGF98d
4FG3
4 5a
RRFDE";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}