// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:[a-z]{2}|[a-z])\d.*$").unwrap();
let string = "AB1ghRjh
c1
G44
Tt7688
kGF98d
4FG3
4 5a
RRFDE";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}