const regex = /^(?:[a-z]{2}|[a-z])\d.*$/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-z]{2}|[a-z])\\d.*$', 'mig')
const str = `AB1ghRjh
c1
G44
Tt7688
kGF98d
4FG3
4 5a
RRFDE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}