package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[a-z]{2}|[a-z])\d.*$`)
var str = `AB1ghRjh
c1
G44
Tt7688
kGF98d
4FG3
4 5a
RRFDE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}