re = /^(?:[a-z]{2}|[a-z])\d.*$/mi
str = 'AB1ghRjh
c1
G44
Tt7688
kGF98d
4FG3
4 5a
RRFDE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end