#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z\d]+)(([A-Z\d]+)*([a-z\d]+)*)*$"
Local $sString = "myVar" & @CRLF & _
"my2varBaz" & @CRLF & _
"myVar2" & @CRLF & _
"myVar2" & @CRLF & _
"myVAR2baz" & @CRLF & _
"myvar" & @CRLF & _
"myVAR" & @CRLF & _
"myVarAndV" & @CRLF & _
"myVARandV" & @CRLF & _
"xmlHTTPRequest" & @CRLF & _
"XMLHttpRequest" & @CRLF & _
"" & @CRLF & _
"MYVAR" & @CRLF & _
"my-var" & @CRLF & _
"Myvar " & @CRLF & _
"my_var" & @CRLF & _
"myV_ar" & @CRLF & _
"my_Var"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")