import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z\\d]+)(([A-Z\\d]+)*([a-z\\d]+)*)*$";
final String string = "myVar\n"
+ "my2varBaz\n"
+ "myVar2\n"
+ "myVar2\n"
+ "myVAR2baz\n"
+ "myvar\n"
+ "myVAR\n"
+ "myVarAndV\n"
+ "myVARandV\n"
+ "xmlHTTPRequest\n"
+ "XMLHttpRequest\n\n"
+ "MYVAR\n"
+ "my-var\n"
+ "Myvar \n"
+ "my_var\n"
+ "myV_ar\n"
+ "my_Var";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}