using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z\d]+)(([A-Z\d]+)*([a-z\d]+)*)*$";
string input = @"myVar
my2varBaz
myVar2
myVar2
myVAR2baz
myvar
myVAR
myVarAndV
myVARandV
xmlHTTPRequest
XMLHttpRequest
MYVAR
my-var
Myvar
my_var
myV_ar
my_Var";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}