// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z\d]+)(([A-Z\d]+)*([a-z\d]+)*)*$").unwrap();
let string = "myVar
my2varBaz
myVar2
myVar2
myVAR2baz
myvar
myVAR
myVarAndV
myVARandV
xmlHTTPRequest
XMLHttpRequest
MYVAR
my-var
Myvar
my_var
myV_ar
my_Var";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}