const regex = /^([a-z\d]+)(([A-Z\d]+)*([a-z\d]+)*)*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z\\d]+)(([A-Z\\d]+)*([a-z\\d]+)*)*$', 'mg')
const str = `myVar
my2varBaz
myVar2
myVar2
myVAR2baz
myvar
myVAR
myVarAndV
myVARandV
xmlHTTPRequest
XMLHttpRequest
MYVAR
my-var
Myvar
my_var
myV_ar
my_Var`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}