$re = '/^([a-z\d]+)(([A-Z\d]+)*([a-z\d]+)*)*$/m';
$str = 'myVar
my2varBaz
myVar2
myVar2
myVAR2baz
myvar
myVAR
myVarAndV
myVARandV
xmlHTTPRequest
XMLHttpRequest
MYVAR
my-var
Myvar
my_var
myV_ar
my_Var';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);