package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z\d]+)(([A-Z\d]+)*([a-z\d]+)*)*$`)
var str = `myVar
my2varBaz
myVar2
myVar2
myVAR2baz
myvar
myVAR
myVarAndV
myVARandV
xmlHTTPRequest
XMLHttpRequest
MYVAR
my-var
Myvar
my_var
myV_ar
my_Var`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}