#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[[:alnum:]]+( [[:alnum:]]+)?$"
Local $sString = "MM56M" & @CRLF & _
"MM 54M" & @CRLF & _
"MMM 5" & @CRLF & _
"555555" & @CRLF & _
"LPOLKG" & @CRLF & _
"MM 5T YU"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")