const regex = /^[[:alnum:]]+( [[:alnum:]]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[[:alnum:]]+( [[:alnum:]]+)?$', 'gm')
const str = `MM56M
MM 54M
MMM 5
555555
LPOLKG
MM 5T YU`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}