// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[[:alnum:]]+( [[:alnum:]]+)?$").unwrap();
let string = "MM56M
MM 54M
MMM 5
555555
LPOLKG
MM 5T YU";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}