import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[[:alnum:]]+( [[:alnum:]]+)?$";
final String string = "MM56M\n"
+ "MM 54M\n"
+ "MMM 5\n"
+ "555555\n"
+ "LPOLKG\n"
+ "MM 5T YU";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}