$re = '/^[[:alnum:]]+( [[:alnum:]]+)?$/m';
$str = 'MM56M
MM 54M
MMM 5
555555
LPOLKG
MM 5T YU';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);