package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:alnum:]]+( [[:alnum:]]+)?$`)
var str = `MM56M
MM 54M
MMM 5
555555
LPOLKG
MM 5T YU`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}