using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[0]{4}86[0-8]{2}\.img
";
string input = @"C:\Users\Dave\Documents\Maps\Data\DemImg\00002639.img
Zambia.img
00002650.img
00008641.img
00008678.img
00008679.img
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}