import re
regex = re.compile((r".*[0]{4}86[0-8]{2}\.img\n"), flags=re.MULTILINE)
test_str = ("C:\\Users\\Dave\\Documents\\Maps\\Data\\DemImg\\00002639.img\n"
"Zambia.img\n"
"00002650.img\n"
"00008641.img\n"
"00008678.img\n"
"00008679.img\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")