use strict;
my $str = 'C:\\Users\\Dave\\Documents\\Maps\\Data\\DemImg\\00002639.img
Zambia.img
00002650.img
00008641.img
00008678.img
00008679.img
';
my $regex = qr/.*[0]{4}86[0-8]{2}\.img
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}