// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*[0]{4}86[0-8]{2}\.img
").unwrap();
let string = "C:\\Users\\Dave\\Documents\\Maps\\Data\\DemImg\\00002639.img
Zambia.img
00002650.img
00008641.img
00008678.img
00008679.img
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}