const regex = /.*[0]{4}86[0-8]{2}\.img
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*[0]{4}86[0-8]{2}\\.img
', 'gm')
const str = `C:\\Users\\Dave\\Documents\\Maps\\Data\\DemImg\\00002639.img
Zambia.img
00002650.img
00008641.img
00008678.img
00008679.img
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}