import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[0]{4}86[0-8]{2}\\.img\n";
final String string = "C:\\Users\\Dave\\Documents\\Maps\\Data\\DemImg\\00002639.img\n"
+ "Zambia.img\n"
+ "00002650.img\n"
+ "00008641.img\n"
+ "00008678.img\n"
+ "00008679.img\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}