$re = '/.*[0]{4}86[0-8]{2}\.img
/m';
$str = 'C:\\Users\\Dave\\Documents\\Maps\\Data\\DemImg\\00002639.img
Zambia.img
00002650.img
00008641.img
00008678.img
00008679.img
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);