package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[0]{4}86[0-8]{2}\.img
`)
var str = `C:\Users\Dave\Documents\Maps\Data\DemImg\00002639.img
Zambia.img
00002650.img
00008641.img
00008678.img
00008679.img
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}