# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)job(.*)/$1$2/gmi;t' <<< "\"Job Care Worker\"
\"+jobs +Nurse\"
\"construction worker\""