re = /(.*)job(.*)/mi
str = '"Job Care Worker"
"+jobs +Nurse"
"construction worker"'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result