const regex = /(.*)job(.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)job(.*)', 'gmi')
const str = `"Job Care Worker"
"+jobs +Nurse"
"construction worker"`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);