use strict;
my $str = '"Job Care Worker"
"+jobs +Nurse"
"construction worker"';
my $regex = qr/(.*)job(.*)/mip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";