# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d+)\b\s*|(.*?)(?=<)<(.*?)>//gm;t' <<< "008800002 Bruxelles-Nord$Br�ussel Nord$<deu>$Brussel Noord$<nld>"