import Foundation
let pattern = #"\b(\d+)\b\s*|(.*?)(?=<)<(.*?)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"008800002 Bruxelles-Nord$Br�ussel Nord$<deu>$Brussel Noord$<nld>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)