re = /\b(\d+)\b\s*|(.*?)(?=<)<(.*?)>/m
str = '008800002 Bruxelles-Nord$Br�ussel Nord$<deu>$Brussel Noord$<nld>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result