$re = '/\b(\d+)\b\s*|(.*?)(?=<)<(.*?)>/m';
$str = '008800002 Bruxelles-Nord$Br�ussel Nord$<deu>$Brussel Noord$<nld>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;