using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)\b\s*|(.*?)(?=<)<(.*?)>";
string substitution = @"";
string input = @"008800002 Bruxelles-Nord$Br�ussel Nord$<deu>$Brussel Noord$<nld>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}