use strict;
my $str = '008800002 Bruxelles-Nord$Br�ussel Nord$<deu>$Brussel Noord$<nld>';
my $regex = qr/\b(\d+)\b\s*|(.*?)(?=<)<(.*?)>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";