# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(\d+)\b\s*|(.*?)(?=<)<(.*?)>"
test_str = "008800002 Bruxelles-Nord$Br�ussel Nord$<deu>$Brussel Noord$<nld>"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.