const regex = new RegExp('^\\s*color: (\\"|\\\\'|).*(\\"|\\\\'|)', '')
const str = ` color: "red"
color: 'red'
color: red
# hoping to do this:
match all 3 lines above and be able to replace any instance of the word red
with my own custom string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}