import re
regex = re.compile(r"^\s*color: (\"|\'|).*(\"|\'|)")
test_str = (" color: \"red\"\n"
" color: 'red'\n"
" color: red\n\n\n\n"
"# hoping to do this:\n\n"
"match all 3 lines above and be able to replace any instance of the word red\n"
"with my own custom string")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")