use strict;
my $str = ' color: "red"
color: \'red\'
color: red
# hoping to do this:
match all 3 lines above and be able to replace any instance of the word red
with my own custom string';
my $regex = qr/^\s*color: (\"|\'|).*(\"|\'|)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}